Sunday, October 7, 2012

Returning the D600

All was going good happy with low light, fps, AF, resolution etc. On a lark, I decided to test for sensor dust. Well, what a mess. Spots all over the place! But these did not look like dust spots. So I cleaned the lens and ran the auto sensor clean. Still there. Did it all again. No change. Tried a different lens. Still there.

At this point I know it is serious, but I really like this camera. So, I go to the local camera store and buy a sensor cleaning kit. I do a cleaning. Still there. Three tries later and no improvement.

So now I am in the process of returning the D600 and the 24-85 vr and looking to find a D600 without this flaw. You may me asking why the 24-85? Here's the rub, while in the camera store I tested the D600 with a 24-70 2.8 and 70-200 vr ii. Gotta have them!

Don't expect any gifts from me this year, I won't have any money!

D600 Dirt or Dust?


Anonymous said...

Noticed something very similar on mine, though much more faded, even at f/16.

Interestingly enough, I don't think these spots were there out of the box as my first few dozen shots didn't exhibit any blobs (and I've gone back to look.)

I'm picking up some cleaning tools tomorrow and really hope that this gets ride of the spots. Unfortunately, the built in sensor cleaning feature didn't work.

Al said...

Even at f/16? At f/16 you will find spots on most cameras unless it has just been well cleaned. It's when you find spots in the f/1.4 - f/8 range that you start to worry.